re = /(?<=\bstyle="[^"]*)#[A-F0-9]{6}\b(?=[^"]*")/m
str = '<span style="color: #FF0000;background-color: #FFFF99;font-family: Calibri;font-size: 11pt;font-weight: bold;font-style: normal">This shouldn\'t be in result #FFFF99</span>
<span style="color: #FF0000;background-color: #FFFF99;font-family: Calibri;font-size: 11pt;font-weight: bold;font-style: normal">This shouldn\'t be in result #FFFF99</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end