$re = '/\b[0-9]{1,2}\s+\S+\s+[0-9]{4}\b/';
$str = 'Votre vol : Casablanca - Paris Mercredi 31 août 2016 AF1197 - Ecoi 7 septembre 2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);