re = /\b[0-9]{1,2}\s+\S+\s+[0-9]{4}\b/
str = 'Votre vol : Casablanca - Paris Mercredi 31 août 2016 AF1197 - Ecoi 7 septembre 2016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end