package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d+?[\+x])?\d+ ?(litros?|u(ni)?ds?|kg|g|cl)(.?, \w+ \d+ ?(litros?|u(ni)?ds|kg|g))?`)
var str = `Aceite de oliva virgen extra CARBONELL, garrafa 3 litros
Aceite de oliva virgen CARBONELL, botella 1 litro
First Bike, bici sin pedales roja,edad rec:2-5 años CHICCO, peso máximo 25 Kg
Bombón de almendras MAGNUM, 3+1 uds., caja 423 g
Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds
Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g
Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g
Cerveza MAHOU 5 Estrellas, pack botellín 12x25 cl
Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}