import re
regex = re.compile(r"(\d+?[\+x])?\d+ ?(litros?|u(ni)?ds?|kg|g|cl)(.?, \w+ \d+ ?(litros?|u(ni)?ds|kg|g))?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Aceite de oliva virgen extra CARBONELL, garrafa 3 litros\n"
"Aceite de oliva virgen CARBONELL, botella 1 litro\n"
"First Bike, bici sin pedales roja,edad rec:2-5 años CHICCO, peso máximo 25 Kg\n"
"Bombón de almendras MAGNUM, 3+1 uds., caja 423 g\n"
"Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds\n"
"Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g\n"
"Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g\n"
"Cerveza MAHOU 5 Estrellas, pack botellín 12x25 cl\n"
"Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")