using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*\.?\d+)(?:[a-zA-Z]+|\([a-zA-Z]+(?:\/\d*(?:[a-zA-Z]+))?\)|(?:,\s+|$))";
string input = @"0, 1, 0.1, .1, 1g, 0.1g, .1g, 1(g/100ml), .1(g/ml), .1, 0, 10(g), .1g, 1, 1.123, 0.1cc, 100(g/1000L),100(mg/1kg)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}