re = /(\d*\.?\d+)(?:[a-zA-Z]+|\([a-zA-Z]+(?:\/\d*(?:[a-zA-Z]+))?\)|(?:,\s+|$))/m
str = '0, 1, 0.1, .1, 1g, 0.1g, .1g, 1(g/100ml), .1(g/ml), .1, 0, 10(g), .1g, 1, 1.123, 0.1cc, 100(g/1000L),100(mg/1kg)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end