$re = '/.*wordA(.+?(?=wordB)).*/m';
$str = 'wordA----------text1-----------wordB-------text2-------------wordB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);