re = /.*wordA(.+?(?=wordB)).*/m
str = 'wordA----------text1-----------wordB-------text2-------------wordB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end