$re = '/^https?:\/\/.+\..+$/m';
$str = 'https://example.com
http://sub.example.org
https://example
example.com
example
https:example.com
https:/example.com
https//example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);