re = /^https?:\/\/.+\..+$/m
str = 'https://example.com
http://sub.example.org
https://example
example.com
example
https:example.com
https:/example.com
https//example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end