#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^[:word:]]*Generated at)[[:space:]]*[^[:space:]*]"
Local $sString = "- * Generated at 2018-11-21" & @CRLF & _
"+ * Generated at 2018-11-23" & @CRLF & _
"+ * This line is important! Although it starts with a * " & @CRLF & _
"+ * Generated at 2018-11-23" & @CRLF & _
"+ * This line should be important, but there it contains a "Generated at"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")