$re = '/^(?=[^[:word:]]*Generated at)[[:space:]]*[^[:space:]*]/m';
$str = '- * Generated at 2018-11-21
+ * Generated at 2018-11-23
+ * This line is important! Although it starts with a *
+ * Generated at 2018-11-23
+ * This line should be important, but there it contains a "Generated at"...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);