use strict;
my $str = '250 Taka.';
my $regex = qr/[^\d]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";