using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<author>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.\s[""“](?<title>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.[""”]\s(?<container>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+),\svol\.\s(?<volume>\d+),\sno\.\s(?<issue>\d+),\s(?<year>[0-9]{4,4}),\spp\.\s(?<pages>\d{1,4}[-–]\d{1,4})\.";
string input = @"Sanders, James A. “The Book of Job and the Origins of Judaism.” Biblical Theology Bulletin, vol. 39, no. 2, 2009, pp. 60–70. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}