# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<author>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.\s[\"“](?<title>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+)\.[\"”]\s(?<container>[A-Z](?:(?!$)[A-Za-z\s&.,'’])+),\svol\.\s(?<volume>\d+),\sno\.\s(?<issue>\d+),\s(?<year>[0-9]{4,4}),\spp\.\s(?<pages>\d{1,4}[-–]\d{1,4})\."
test_str = "Sanders, James A. “The Book of Job and the Origins of Judaism.” Biblical Theology Bulletin, vol. 39, no. 2, 2009, pp. 60–70. "
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.