use strict;
my $str = 'c1c425268e68385d1ab5074c17a94f14';
my $regex = qr~^..(..).+~mp;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";