$re = '/\/\*[^\/]+[^\*]+\*\//m';
$str = '/* 1111 */ one /*2222*/two /*3333 */ three/* 4444*/ four /**/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);