re = /\/\*[^\/]+[^\*]+\*\//m
str = '/* 1111 */ one /*2222*/two /*3333 */ three/* 4444*/ four /**/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end