use strict;
my $str = '英文 中文 English something else';
my $regex = qr/(?<![a-z]) | (?![a-z])/ip;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";