$re = '/(?<![a-z]) | (?![a-z])/i';
$str = '英文 中文 English something else';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;