package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+/\d+/\d+, \d+:\d+\d+) - (.+?): (.*)`)
var str = `20/01/18, 08:11 - Peter: Good morning
How are you?
Peter
20/01/18, 09:00 - Caroline: I am fine thanks.
You?
20/01/18, 09:01 - Peter: Good
I had some problems few days ago.
Now I am happy
Are you working?
20/01/18, 09:02 - Caroline: No I have to go to the supermarket to buy vegetables
20/01/18, 09:12 - Peter: Nice!
Where are you now?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}