re = /(\d+\/\d+\/\d+, \d+:\d+\d+) - (.+?): (.*)/
str = '20/01/18, 08:11 - Peter: Good morning
How are you?
Peter
20/01/18, 09:00 - Caroline: I am fine thanks.
You?
20/01/18, 09:01 - Peter: Good
I had some problems few days ago.
Now I am happy
Are you working?
20/01/18, 09:02 - Caroline: No I have to go to the supermarket to buy vegetables
20/01/18, 09:12 - Peter: Nice!
Where are you now?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end