$re = '/^(?!BG)(?!GB)(?!NK)(?!KN)(?!TN)(?!NT)(?!ZZ)[A-Z]*[^DFIQUV][A-Z]*[^DFIOQUV][0-9]{6}[A-D]$/m';
$str = 'AA010101A';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;