re = /^(?!BG)(?!GB)(?!NK)(?!KN)(?!TN)(?!NT)(?!ZZ)[A-Z]*[^DFIQUV][A-Z]*[^DFIOQUV][0-9]{6}[A-D]$/m
str = 'AA010101A'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result