package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S{5,})@(gmail|hotmail).com`)
var str = `.....@gmail.com
@@@@@@hotmail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}