$re = '/(\S{5,})@(gmail|hotmail).com/m';
$str = '.....@gmail.com
@@@@@@hotmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);