use strict;
my $str = '(1+2) / 2
1/2+4/5';
my $regex = qr/(?<=[^\s/])(?=[^\s/])/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";