#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(?<!#)[a-zA-z,.:]+"
Local $sString = "This is a #text, which is #full of #hashtags." & @CRLF & _
"Well, this is not #easy to" & @CRLF & _
"#extract #them. " & @CRLF & _
"I think I #start to lose: #hope."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)