const regex = /\b(?<!#)[a-zA-z,.:]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!#)[a-zA-z,.:]+', 'gm')
const str = `This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to lose: #hope.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);