using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id\=\""(?<id>[a-zA-Z][^_]+(\.*))";
string input = @"10-10-2019 14:04:25.863 +0200 WARN DispatchSjaak - Queued job id=""c1111__c63422sss23344__search__search12339_157e345.73734_AF27BCF9-C4E0-4D04-B4E3-3r"", seadex=application_wab_p
id=""w34_aW0uY3Jpc2lz_aW0uY3Jpc2lz__search__search36_15703344710104.14022286_FB3D64CC-984D-4FAB-B724-5D14BA490FE3AppID == ""ANDROID"", ""MB Android App"", search_id=""1570701613.3403_5F230059-1DF0-4750-B165-087Der444425949E17"" - QUEUED reason=""The maximum nu
= ""HELL"", ""MB"", search_id=""xxx1570701613.3403_5F230059-1DF0-4750-B165-087Der444425933244349E17"" - QUEUED reason=""The maximum nu";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}