// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)id\=\"(?<id>[a-zA-Z][^_]+(\.*))"#).unwrap();
let string = "10-10-2019 14:04:25.863 +0200 WARN DispatchSjaak - Queued job id=\"c1111__c63422sss23344__search__search12339_157e345.73734_AF27BCF9-C4E0-4D04-B4E3-3r\", seadex=application_wab_p
id=\"w34_aW0uY3Jpc2lz_aW0uY3Jpc2lz__search__search36_15703344710104.14022286_FB3D64CC-984D-4FAB-B724-5D14BA490FE3AppID == \"ANDROID\", \"MB Android App\", search_id=\"1570701613.3403_5F230059-1DF0-4750-B165-087Der444425949E17\" - QUEUED reason=\"The maximum nu
= \"HELL\", \"MB\", search_id=\"xxx1570701613.3403_5F230059-1DF0-4750-B165-087Der444425933244349E17\" - QUEUED reason=\"The maximum nu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}