import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?#DDI)(?:\\+|00)?(55)\\s?)?(?:(?#DDD)\\(?([1-9][0-9])\\)?\\s?)(?:(?#Telefone)((?:9\\d|[2-9])\\d{3})\\-?(\\d{4}))$";
final String string = "Original: ^(?:(?:\\+|00)?(55)\\s?)?(?:\\(?([1-9][0-9])\\)?\\s?)?(?:((?:9\\d|[2-9])\\d{3})\\-?(\\d{4}))$\n"
+ "Alterada: ^(?:(?:\\+|00)?(55)\\s?)?(?:\\(?([1-9][0-9])\\)?\\s?)(?:((?:9\\d|[2-9])\\d{3})\\-?(\\d{4}))$\n\n"
+ "+5511988887777\n"
+ "0055 (11) 98888-7777\n"
+ "+55 988887777\n"
+ "988887777\n"
+ "(11) 98888-7777";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}