const regex = /^(?:(?#DDI)(?:\+|00)?(55)\s?)?(?:(?#DDD)\(?([1-9][0-9])\)?\s?)(?:(?#Telefone)((?:9\d|[2-9])\d{3})\-?(\d{4}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?#DDI)(?:\\+|00)?(55)\\s?)?(?:(?#DDD)\\(?([1-9][0-9])\\)?\\s?)(?:(?#Telefone)((?:9\\d|[2-9])\\d{3})\\-?(\\d{4}))$', 'gm')
const str = `Original: ^(?:(?:\\+|00)?(55)\\s?)?(?:\\(?([1-9][0-9])\\)?\\s?)?(?:((?:9\\d|[2-9])\\d{3})\\-?(\\d{4}))\$
Alterada: ^(?:(?:\\+|00)?(55)\\s?)?(?:\\(?([1-9][0-9])\\)?\\s?)(?:((?:9\\d|[2-9])\\d{3})\\-?(\\d{4}))\$
+5511988887777
0055 (11) 98888-7777
+55 988887777
988887777
(11) 98888-7777`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}