package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-IK-Z]a?\d{1,3}[a-zA-Z]?(?:-[a-zA-IK-Z]a?\d{1,3}[a-zA-Z]?)*$`)
var str = `Aa200-B300-M52A-G5-Aa50
Aa200-B300-M52A-G5-A
Aa200-B300-M52A-G5-Aa
Aa200-B300-M52A-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}