$re = '/^[a-zA-IK-Z]a?\d{1,3}[a-zA-Z]?(?:-[a-zA-IK-Z]a?\d{1,3}[a-zA-Z]?)*$/m';
$str = 'Aa200-B300-M52A-G5-Aa50
Aa200-B300-M52A-G5-A
Aa200-B300-M52A-G5-Aa
Aa200-B300-M52A-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);