#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z_$][0-9a-zA-Z_$]*$"
Local $sString = "abc" & @CRLF & _
"$1" & @CRLF & _
"_asd" & @CRLF & _
"1" & @CRLF & _
"$___1" & @CRLF & _
"__asa" & @CRLF & _
"$asda"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")