$re = '/^[a-zA-Z_$][0-9a-zA-Z_$]*$/m';
$str = 'abc
$1
_asd
1
$___1
__asa
$asda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);