import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b(?:your|amazon\\.com|shipped)\\b.*){3}";
final String string = "Your Amazon.com order has shipped (#114-7286434-0549003)\n\n"
+ "Fwd: Your Amazon.com order of \"Diva Ring Light Nebula 18...\" has shipped!\n\n"
+ "Your Amazon.com order has shipped (#114-7286434-0549003)\n\n"
+ "Your Amazon.com order has shipped\n\n\n\n"
+ "Fwd: Your sdjcns order has deleted\n\n"
+ "Fwd: Your amazon order is cancelled\n\n"
+ "Your Amazon.in order (#171-8110001-7994703) of \"Prestige Electric Kettle...\" has been dispatched!\n\n"
+ "Your Amazon.in order #171-8110001-7994703 has been delivered\n\n"
+ "Your Amazon.in order #171-8110001-7994703 is out for delivery\n\n"
+ "Your Amazon.in order #171-8110001-7994703 has been shipped\n\n"
+ "Fwd: Your Amazon.com order of \"Diva Ring Light Nebula 18...\" has shipped!";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}