// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:\b(?:your|amazon\.com|shipped)\b.*){3}").unwrap();
let string = "Your Amazon.com order has shipped (#114-7286434-0549003)
Fwd: Your Amazon.com order of \"Diva Ring Light Nebula 18...\" has shipped!
Your Amazon.com order has shipped (#114-7286434-0549003)
Your Amazon.com order has shipped
Fwd: Your sdjcns order has deleted
Fwd: Your amazon order is cancelled
Your Amazon.in order (#171-8110001-7994703) of \"Prestige Electric Kettle...\" has been dispatched!
Your Amazon.in order #171-8110001-7994703 has been delivered
Your Amazon.in order #171-8110001-7994703 is out for delivery
Your Amazon.in order #171-8110001-7994703 has been shipped
Fwd: Your Amazon.com order of \"Diva Ring Light Nebula 18...\" has shipped!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}