$re = '/\[(\d+)]|\((\d+)\)/m';
$str = ' I love [123] and [124] at (456). I hate [234] and [235] at (123).
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);