re = /\[(\d+)]|\((\d+)\)/m
str = ' I love [123] and [124] at (456). I hate [234] and [235] at (123).
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end