package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[~#\*]|(<\/?[^>]+?>)`)
var str = `<H1>Это тестовое выражение</H1>
# Еще одно тестовое выражение`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}