$re = '/[~#\*]|(<\/?[^>]+?>)/';
$str = '<H1>Это тестовое выражение</H1>
# Еще одно тестовое выражение';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);