use strict;
my $str = 'loc=/abc/flows/timespan/2021-08-10T11:35:00+00:00_2021-08-10T12:35:00+00:00/ip_initiate/10.101.10.20/data.ext
loc=\\"{\\"type\\":1,\\"namespace\\":\\"flows\\",\\"appIds\\":\\"10,11,12\\",\\"path_bar\\":\\"[\\\\\\"ip_initiate=10.1.120.11\\\\\\"]\\",\\"2021-08-10T11:35:00+00:00_2021-08-10T12:35:00+00:00\\\\/ip_initiate\\\\/10.1.120.11\\\\/http_code\\\\/200\\",\\"restrict\\":null}\\"", day=xyz
loc=\\"{\\"type\\":1,\\"namespace\\":\\"flows\\",\\"appIds\\":\\"10,11,12\\",\\"path_bar\\":\\"[\\\\\\"ip_initiate=10.1.120.11\\\\\\"]\\",\\"2021-08-10T11:35:00+00:00_2021-08-10T12:35:00+00:00\\\\/ip_initiate\\\\/10.1.120.11\\\\/http_code\\\\/200\\",\\"restrict\\":null}\\"", ip=10.10.10.10
loc=\\"/timespan/2021-09-12T14:21:00/ip_responder/10.10.10.10/,country=xyz,dns=example.com,http:code=2548:111:0:0:0:0:182.25.236.2:10\\"';
my $regex = qr/loc=((?:(?!\s,).)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}