re = /.*Replace(.*)/m
str = 'Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end