re = /(www.)?[^@]\w+\.+\w{2,3}/
str = 'Lorem www.example.in ipsum #web-developer dolor sit amet, consectetur adipiscing elit. Donec suraj@mishra.com consequat sem eros, et volutpat google.com lacus dignissim ac. Pellentesque ac nisl et erat porta feugiat. +91-141-2561894 Vestibulum #web_designing sodales semper stackoverflow.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end