import Foundation
let pattern = #"(www.)?[^@]\w+\.+\w{2,3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"Lorem www.example.in ipsum #web-developer dolor sit amet, consectetur adipiscing elit. Donec suraj@mishra.com consequat sem eros, et volutpat google.com lacus dignissim ac. Pellentesque ac nisl et erat porta feugiat. +91-141-2561894 Vestibulum #web_designing sodales semper stackoverflow.com"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)