package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\w*[aeiou]{2}\w*[aeiou]{2}\w*`)
var str = `vision proof
visionproof`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}