$re = '/\w*[aeiou]{2}\w*[aeiou]{2}\w*/mi';
$str = 'vision proof
visionproof';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);